Upgrade to latest version of Flash Player

We advise that you have the latest version of Flash on your computer before attempting to complete your interview.

For interview recording purposes 11.0 is required as a minimum, but we would advise using 11.6+ as a minimum. Older versions of Flash can cause issues with the video recording process. You will be prompted to download this version when you start the application.

You can check the version of flash you have installed here:  What version of flash player do I have

The Latest version of Flash player can be found here: Latest version



Should you still have problems just get in touch with Sonru Support.

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request